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Lesson summary 
Problems with eutrophication and algal blooms around the world have generated the need 
for cost-effective ways of monitoring the ecological status of water bodies and its changes. 
Earth Observation methods have proved to give far better coverage both in spatial and 
temporal scale for evaluation of in-water constituents in the water bodies. 

In this lesson we will learn how to analyse the spatial variability in algal concentrations in 
Lake Peipsi, Estonia, using MERIS satellite data. This includes some basic handling of the 
image, atmospheric correction, application of a concentration-retrieval algorithm and finally 
validation of the results with in situ measurements 

 
 

GLaSS training material outline 
This lesson is part of the GLaSS training material. The complete training material outline is 
listed on http://data.waterinsight.nl/GLaSS/trainingmaterials/GLaSS_lesson_outline.pdf. 

Note that the lessons logically follow up on each other, the later lessons might require skills 
that can be acquired during the earlier lessons. 

http://data.waterinsight.nl/GLaSS/trainingmaterials/GLaSS_lesson_outline.pdf
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List of abbreviations 
Abbreviation   Description 
Chl-a Chlorophyll a 
CY Cyanobacteria 

EO Earth observation 
FLH Fluorescence line height 
Ltoa Top-of-the atmosphere radiance 

MERIS Medium Resolution Imaging Spectrometer 
PC Phycocyanin (pigment in cyanobacteria) 
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1 Introduction 

1.1 Eutrophication of lakes 
Problems with eutrophication and algal blooms all around the world (Hallegraef, 2003;  
Glibert et al., 2005;  Steffensen, 2008; Smith & Schindler, 2009, Paerl et al., 2011) have 
generated the need for cost-effective ways of monitoring  the ecological status of water 
bodies and its changes. Presently the routine field monitoring is both time- and resources-
consuming, being able to cover only few field sites with the maximum frequency of once a 
month or even less for smaller lakes. The applications of the Earth Observation (EO) 
methods have proved to give far better coverage both in spatial and temporal scale for 
evaluation of in-water constituents in the water bodies (Kutser, 2009; Eleveld, 2012; Zhu et 
al., 2014). Since all these lakes are shallow, information about the surface layer, as achieved 
with EO methods, reflects the entire water column, whereas in case of deeper lakes the 
surface layer is not representative for the deeper layers. 

Problems that occur in many shallow eutrophic lakes (GlaSS Deliverable 5.2, 2015) are: 

• Shallow, vulnerable to eutrophication and sediment resuspension 

• Suffer from overload of nutrients to a lake, which can originate from rivers, runoff of 
nearby agricultural areas, from air pollution and from sewage systems. These diverse 
inputs, and the historic load of nutrients in the sediments of the lake that can easily 
resuspend (self-contamination), make it hard to restore lower nutrient concentrations  

• Presence of potentially toxic cyanobacteria (CY) blooms, which reduce the value of a 
lake 

Many eutrophic lakes are located in highly populated areas. Discharge of nutrient sewer and 
runoff of water from land that is use for intensive farming are factors that contrinbute to the 
eutrophication. On the other hand, especially in highly populated areas, lakes are expected 
to provide ecosystem services: drinking water source, shipping, fishing, irrigation, recreation 
– many of those actions may be halted due to CY blooms.  

These lakes are characterized by periodically high Chl-a concentration, mainly due to CY 
mass development. In the temperate zone the occurrence of CY blooms is most pronounced 
during summer months, coinciding with the period of higher water demand for irrigation and 
recreational purposes (Codd et al., 2005a; Merel et al., 2013, Macario et al., 2015).  

Historically, phosphorus (P) has been the priority nutrient controlling freshwater productivity, 
whereas nitrogen (N) limitation has characterized coastal waters (Likens, 1972), and these 
have remained to be the key nutrients limiting aquatic plant primary production and biomass 
formation (Paerl, 2009). Usually P is in the focus (Schindler, 1977, Sterner, 2008), but also a 
co-limitation of N and P might occur (Elser et al., 2007, Müller & Mitrovic, 2015), or different 
nutrients are limiting at different time period of the year (Xu et al., 2013). Heterocysteous CY 
will benefit from N limitation due to their ability to fix their own nitrogen and outcompeting 
other algal groups (e.g. chlorophytes) in that way. Diazotrophic CY make an important 
contribution to N-limited system: fixed nitrogen is afterwards efficiently assimilated and 
transferred in food webs directly by grazing on fresh or decaying CY and indirectly through 
the uptake by other phytoplankton and microbes of bio-available nitrogen exuded from CY 
cells (Karlson et al., 2015). 

Generally, eutrophication is related to extensive nutrient input from both agricultural and 
industrial runoff, either from point or diffuse sources. A relatively small water volume makes 
shallow lakes vulnerable to eutrophication. Small and shallow lakes are the major target of 
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various restoration projects. There is a clear knowlegde that before any lake restoration 
measures are taken, the first step is nutrient reduction in incoming water. If this is not done, 
restoration measures have practically no effect (Cooke et al., 2005). It is relatively easy to 
reduce nutrient income from point sources, and especially P reduction, but tackling diffuse 
pollution is much harder. For example in case of Lake Erie: despite decades of international 
efforts to reduce nutrient loading, this lake still receives extensive nutrient input (Waples, 
2008) and both the duration and toxicity of CY blooms have increased (Stumpf et al., 2012).  

1.2 Effect of cyanobacteria blooms  
Many shallow lakes suffer under massive development of CY, which affect water quality by 
biomass accumulation, generating surface scum, producing toxic compounds (Znachor et al., 
2006, Paerl & Huisman, 2009), and altering the pH and O2 regime (Havens, 2007). This 
leads to altering of the food webs and posing a major threat to drinking and irrigation water 
supplies, fishing and recreational use of surface waters worldwide (Paerl & Huisman, 2009). 
Decay of dead organic material leads to lack of oxygen in lower parts of the water column, 
and in anoxic conditions P is released from sediments back to the water column, causing 
secondary nutrient pollution with more algal mass. 

An estimated 40 genera of freshwater CY are known to form toxic blooms (Mazur & Plinski, 
2003), common blooms-formers are Dolichospermum (former Anabaena), Aphanizomenon, 
Microcystis, Planktothrix, Gloeotrichia. Presence of CY blooms generally lowers the quality of 
ecosystem services, which lakes are assumed to provide (recreational value, both 
commercial and recreational fishing, drinking and irrigation water), whereas blooms are 
anticipated to increase in frequency and intensity due to climate change (Moss, 2012). 
Intensity of blooms is related to water temperature (“blooms like it hot”, Paerl & Huisman, 
2008), increased nutrient amount, inability of grazers due to unpalatability (large colonies, 
long filaments, mucus, toxin production) (Huddnell & Dortch, 2008). Still, zooplankton that are 
“used to” live with toxic CY are not inhibited by their toxicity and consumption of toxic CY 
cells has been seen both in situ and in various experiments, whereas an increase in the 
viable egg production was shown (Hogfors et al., 2014). Bloom-forming species of CY are 
successful due to their higher temperature optimum, UV-tolerance, ability to fix nitrogen, 
production of gas-vacuoles, which allow moving to the best position in water-column, and 
toxin production (Oliver & Ganf, 2002). They prefer a stable and stratified water column: 
mixing caused by wind or other forces tends to generate unfavorable conditions, affecting 
negatively both metabolism and growth (Paerl, 2002). Not all bloom-forming CY fix nitrogen, 
non-heterocysteous species like Microcystis prefer conditions with higher nitrogen amount 
(Hudnell et al., 2008).  

There is a historical knowledge about cattle, dog and wildlife poisonings together with human 
illnesses due to CY blooms in all continents (Codd et al, 2005b, review by Steffen et al., 
2014). CY may produce three major types of toxins: neurotoxins (anatoxin and saxitoxin), 
hepatotoxins (microcystin, nodularian, cylindrospermopsin) and various skin and 
gastrointestinal toxins; often several different toxins are produced simultaneously (Backer et 
al., 2015). An overview of produced toxins is given by Paerl & Otten (2013). Hepatotoxins are 
associated with liver cancer (Zhang et al., 2015) and other tumours in humans and wildlife 
(Charmichael, 2001). Problematic is that presence of CY does not automatically mean that 
toxins are produced, and thus is impossible to say via EO methods whether the threat is real 
or only potentially there. Despite of that shortcoming, there is a strong need to monitor and 
forecast CY blooms, and remote sensing methods provide a cost-efficient opportunity 
(Kudela et al., 2015).  
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Although there is a myriad of semi-analytical methods and methods using spectral shape, an 
issue is the relative unavailability of sensors with both fine spectral and spatial resolution 
(Kudela et al., 2015). ESA’s OLCI on board of Sentinels 2 (S2) and 3 (S3) will hopefully solve 
that problem. Because these sensors are not yet operational by the time of writing this 
lesson, for the current lesson we will work with MERIS. MERIS serves as a proxy for S3 
OLCI: in principle, S3 OLCI data can be used in the same way as MERIS data, using the 
same algorithms and assumptions.  

Identification of CY blooms by optical detection methods is based on algorithms targeting 
phycocyanin (PC) (overview in Kutser, 2009). Phycocyanin is a pigment-protein complex, 
specific to CY, with absorption maximum around 620 nm. Mishra & Mishra (2014) review five 
main types of algorithms that have been developed to estimate phycocyanin concentration 
from EO data. They also proposed a newest PC algorithm, suitable for MERIS-like sensors 
(training range of PC 68.13 to 3032.47 mg/m3), but also admit, that there are still problems 
with correct detection of PC at low to medium amounts. Since the in situ measured CY 
biomass or phycocyanin concentration is often lacking, there is a strong demand for both 
accurate satellite PC products in lakes as well as for in situ data for model validation. 
Horwath et al. (2013) showed that PC fluorescence is strongly correlated with extracted PC 
amount, but according to Macario et al. (2015) the amount of PC in cells is species-specific 
and fluorescence spectra depend on many factors, e.g. cell density in colony, cell size, light 
conditions and nutrients.  

Except by monitoring PC to trace CY blooms, it is also possible to monitor Chlorophyll-a (Chl-
a). Chlorophyll-a is not specific to CY: all autotrophic phytoplankton contains Chl-a, like 
diatoms and green algae, which are also abundant in lakes. However, it is known that toxin 
concentrations of toxin producing cells increase with cell density. Therefore, according to 
WHO (2003) ‘For practical purposes, the present state of knowledge implies that health 
authorities should regard any mass development of cyanobacteria as a potential health 
hazard’. High concentrations Chl-a indicate a phytoplankton bloom, which is potentially a 
toxin producing CY bloom, but could also be a harmless green algae bloom. Because of the 
validation issues for PC, this exercise will focus on Chl-a.  

1.3 Lake Peipsi - Estonia 
Lake Peipsi is located in Eastern Estonia on the border of Russia and Estonia, being the 
largest trans boundary water body in Europe. It consists of three parts: the largest and 
deepest mesotrophic Lake Peipsi s.s., the middle strait-like eutrophic Lake Lämmijärv and 
hypertrophic Lake Pihkva, which belongs entirely to Russia. Lake Peipsi has a surface area 
of 3555 km2, a maximum depth of 15.3 m, a mean depth of 7.1 m, a water volume of 25 km3, 
and a catchment area of 47800 km2. Its surface elevation is 30 m. The majority of nutrients 
are carried into the lake by the rivers Velikaja and Emajõgi: from the total drainage basin of 
Lake Peipsi the catchment areas of those two rivers cover up to 80% of the area (Loigu et al., 
2008). The largest part of the catchment area belongs to Russia (58%), to Estonia (34%) and 
the rest 8 % belongs to Latvia and Belarus (Jaani, 2001). According to Buhvestova et al. 
(2011) major Estonian rivers discharged approximately 5600 t of nitrogen (mainly during 
winter and spring) and 179 t of phosphorus annually to Lake Peipsi. There is also a spatial 
variation in in-lake nutrient content: the northern part has always been significantly poorer 
than the southern part (Kangur & Möls, 2008). In-lake phosphorus concentrations were not 
found to be sensitive to year-to-year changes in riverine nutrient loads (Buhvestova et al., 
2011), leading to assumption of the importance of self-contamination due to P-rich 
sediments.  
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In Lake Peipsi the dominant algal complex has not changed essentially during the 20th 
century, and blooms of Gloeotrichia were recorded already 100 years ago (Kullus, 1964). 
Nowadays every part of Lake Peipsi shows an increasing trend of CY biomass based on in 
situ data, which is most pronounced in the southern parts of the lake (Laugaste et al., 2007). 

 
Figure 1. Map of Lake Peipsi with national monitoring points. Points 2,4,11,38,16,17 are 
visited once a month from May to September, rest of the points once a year during August.  

From ecosystem services perspective, besides recreational activities like boating, swimming, 
skating and recreational fishing, Lake Peipsi provides 80-88% of freshwater fish catches in 
Estonia, whereas 3-10 % is caught from Lake Võrtsjärv and 1-2 % from the rest of 
waterbodies. In fish catch dominate mainly warm-water species (bream, pikeperch, perch, 
pike, roach), whereas cold-water fishes (smelt, whitefish, burbot, vendace) are in decline.  

Fish catch (ton per year): From „Fish catches.., 2014“.  
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The problem with vendace reflects the ecosystem instability of Lake Peipsi. Vendace is a 
cold-water species, which was abundant during 1970/80 (catch 1000-3000 t/year). Vendace 
population collapsed during 1991-1994 (with no catch), then recovered with 167 t catch 
during 1998, but during 2001-2011 catch was again zero or close to it. Since 2011 a slow 
recovery is visible. There is no single reason behind the decline, but rather a combination of 
environmental factors (Kangur et al., 2005; Kangur et al., 2007, Kangur et al., 2013): 

1. Increase in water temperature > 20°C during summer; 

2. Effect of CY blooms is also noted as an important factor: changes in oxygen regime, 
increase in pH and possible effect of toxins; 

3. Increase in predator abundance e.g. pikeperch; 

4. Eutrophication: siltation of spawning grounds. 

Recreational fishing is also popular during wintertime: up to 3000 anglers were observed at 
weekends on the Estonian side of the ice-covered lake (Orru et al., 2014). Lake Peipsi is an 
internationally important bird area (partly of the Natura 2000 area) with more than 100 
different species of water-and swamp-related birds. Altogether is found 266 bird species, 
including 180 nesting species, 71 passaging species and 15 occasionally present species 
during last 50 years (Luigujõe et al., 2008).  

1.4 Short intro on atmospheric correction 
It is important to realise that most of the signal, minimal 90%, that is received by the satellite 
is caused by reflection of sunlight on the atmosphere (National Research Council, 2011).  
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Figure 2. This figure above shows the most common routes of sunlight on its way to a 
satellite above the sea. Ray 1 is absorbed by the atmosphere and never reaches the water 
surface and the sensor. Rays 2 and 3 are respectively absorbed and scattered by the water 
or its contents and so never reach the sensor. Rays 4, 5, 6 and 7 reach the sensor. However, 
only ray 5 is interesting for water quality monitoring. This ray is partly absorbed by water or 
its contents, but enough is scattered over an angle > 90° (backscattered) to reach the sensor. 
Rays 4, 6, and 7 are, respectively, reflected by the sea floor, by the water surface and 
scattered by the atmosphere. Combinations of these routes can also occur. (Figure and text 
taken from Hommersom, 2010, with permission). 

Atmospheric correction methods try to remove the atmospheric effects from the signal as it is 
received by the satellite, on top of the atmosphere (TOA). On its way to the satellite, the light 
penetrates the atmosphere twice: from sun into the water and back to the sensor. Processes 
such as adjacent scattering from land into the light path can also be considered as part of 
atmospheric correction, or correction for water surface impacts to retrieve the pure 
reflectance of the water bulk. As a minimum, bidirectional effects of scattering and absorption 
in atmosphere under varying aerosol optical depth are usually accounted for. Some 
atmospheric correction methods apply constant aerosol optical properties over the scene, 
while others reflect the atmospheric heterogeneity and retrieve an actual aerosol properties 
per pixel. While the first approach is often subject to large uncertainties and is applicable only 
for small areal extend, the second method is required for processing of large data quantities 
or large areas in an operational environment. However, this requires a certain spectral 
resolution and radiometric quality of the sensor. 

Within the project GLaSS, existing atmospheric correction methods were investigated. The 
selected methods covered both commercial (MIP, ATCOR) and open source available 
algorithms, which are implemented e.g. in BEAM like FUB or C2R. Moreover, some of the 
methods (e.g., C2R and MIP) were specifically developed to correct the atmospheric effect 
for water body, while others are general purpose atmospheric correction methods (e.g., 
ATCOR and SCAPE-M) for EO data over Earth surfaces. The first class of methods usually 
estimate the water leaving radiance reflectance or remote sensing reflectance or similar 
quaintest which are properly defined for water body only. Moreover, these methods are 
usually coupled with retrieval of water constituents. Instead, the not water oriented 
atmospheric processor methods provide a dimensionless surface reflectance value whose 
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transformation into water leaving radiance reflectance (or remote sensing reflectance) require 
further computation such as the air/water interface correction, the assumption of the light field 
shape (e.g. Q factor) or further corrections for the specularly reflected sun and sky radiance. 
GLaSS compared the methods based on access and licences, implementation, configuration 
options, processing efforts, applicability to different satellite sensors and performance on 
inland waters. In general, the development of atmospheric corrections for inland waters is a 
very dynamic field and a lot of investigations and developments are ongoing. There was no 
'generally better' algorithm, instead, depending on the lake type and the situation (specific 
atmospheric properties are known or not, funding for licences available or not etc) the report 
(GLaSS Deliverable 3.2, 2014) will help to select the most suitable method for a specific 
case.  

In this lesson we will use the CoastColour atmospheric correction method. It was the one 
performing the best for Lake Peipsi and no commercial software is required for running it. 
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2 This lesson 

2.1 Research question 
What is the spatial distribution of Chl-a over Lake Peipsi? 

2.2 Training objectives / skills to gain in this lesson 
Learn how to use satellite data to retrieve chlorophyll concentrations, as a proxy for 
eutrophication. 

1. Open an optical satellite image and perform some visual analysis on spatial variability 
2. Apply an atmospheric correction method 
3. Validate the results with in situ data (spectral + concentrations) 

2.3 Required software and data 

Software and tools 
To complete this lesson tasks, the following tools and software are required or suggested: 

• BEAM (required, see Lesson #1). 
SNAP2.0 cannot be used, but later versions that include the CoastColour processing 
can be used. As it is expected that SNAP will mostly be used in future, most 
screenshots in this lesson (except those including the CoastColour processing) are 
based on SNAP. 

Downloadable files 
• GLaSS_Training_Lesson3.pdf 

The main document of the lesson including exercises and questions. 

• GLaSS_Training_Lesson3_Answers.pdf 
A document containing answers to all questions proposed in the exercises. 

• GLaSS_Training_Lesson3_DataAndTools.zip 
Supplied data and tools, described below. 

The zip-file with supplied data and tools contain:  

• A folder ‘Original satellite data’, containing two original MERIS images (e.g. 
MER_FRS_1PPBCM20110708_090036_000001013104_00194_48915_0277.N1) 

• A folder called ‘In situ data’, containing two (Excel) spreadsheets with in situ data: 

o ‘In_situ_reflectances.xlsx’ 
o ‘In_situ_chlorophyll.xlsx’ 

• A folder called ‘Additional data’, containing:  

o A file with the in situ locations, in BEAM/SNAP format: 
In_situ_locations.placemark 

o Two files with a colour scale to use in BEAM/SNAP: e.g. 
Chlorophyll_colour_scale.cpd 

• A ‘Answer data’ folder containing the same imagery as provided in the Original 
satellite imagery and In situ data folders, after performing the steps that are explained 
in the lesson 
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3 Exercise 

Part 1 Basic visual analysis of spatial variability 
 Start SNAP 

 Open the MERIS image of 27th July 2011 (File > Open Product > select the image 
MER_FRS_1PPBCM20110727_090357_000001013105_00036_49188_0274.N1). 

• “FRS” stands for the full resolution, which means the ~300*300 m pixel size. 
MERIS imagery is also available at reduced resolution of ~1*1 km. 

• “1P” stands for L1P processing level. L1 is on top of the atmosphere, e.g. what 
the satellite records, including the atmospheric effects. P is the standard pre-
processing applied. 

• “20110727” is the date when the image was taken (27th of July 2011). 

• “090357” is the time when image was taken in UTC (09:03:57) 

• “N1” is the file type of original MERIS images. 

After opening, in the "Product Explorer" window (left side of your screen) you can click the +-
signs to open the folders for the Metadata, Flag codings, Tie-point grids and Bands.  

To easily get an idea of what the image looks like: 

 Right-click the image in the Product Explorer > Open RGB Image Window >> it 
automatically selects MERIS L1P Tristimulus 
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You now get to see the Gulf of Finland and surrounding land. Zoom in and out with the 
mouse and click-move around to see if you can find Lake Peipsi. 

It is easier and it will save a lot of memory on your computer if you cut out the part of the 
image that you are interested in, in this case Lake Peipsi. To apply such a bounding box and 
save that part of the image: 

 File > Export > BEAM-DIMAP 

 Subset > Geo Coordinates >> fill out the coordinates: 59.1360 North, 27.0140 West ; 
57.7640 South, 28.1470 East (note that for locations of the Southern hemisphere you 
need to use the minus sign) 

 Make sure you select a folder where you can find the exported image > Export 
Product 

 
To further work with the small file: 
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 File > Close Product 

 File > Open Product >> select the just exported file 

For a more detailed look: 

 Open again a RGB image view (Right-click the image in the Product Explorer > Open 
RGB Image Window > MERIS L1P Tristimulus) 

 Select the Colour Manipulator tab (   ) (or next to navigation) 

 Adjust the colours by selecting the “Red” slider and moving it to the left, where the 
higher values of the histogram are found. Then select “Green” in the Colour 
Manipulator window to adjust green in the same way, and finally also “Blue”. 

 
After some playing around with this, you should be able to see the spatial variability in the 
lake. 

On a first glance, already some basics can be seen: 

• The white dots on land are clouds, those are the most bright 

• Land is relatively bright, water is the darkest 

• The northern part of Lake Peipsi (Peipsi s.s (sensu stricto) is darker than the southern 
part (Lake Pihkva). Lake Pihkva contains more suspended sediments (TSM), which 
reflect the light and therefore causing the water to have a higher reflection than the 
northern part of the lake. 

• In Lake Pihkva and also to a lesser extent in Lake Peipsi s.s., some spatial features 
of a mixture of Chl and TSM can be seen. 

If you adjust the colours even more, also features in the northern part become more 
pronounced. Also a vertical line will become visible. This shows that the image is composed 
of two cameras of the MERIS instruments that are slightly different. 

You can leave the image open for the next part of the exercise. 
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Part 1 Extra analysis 
 Open the other MERIS .N1 file 

(MER_FRS_1PPBCM20110708_090036_000001013104_00194_48915_0277.N1)  

 Select it in the Product Explorer by clicking it 

 Analyse it. You can make a subset, open RGB image view, zoom in and out.  

o What can be seen just next to the clouds? 

 
Close all the products you opened in this extra section by selecting them in the product view 
> File > Close Product (this needs to be done per image). 
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Part 2 Atmospheric correction 
First make sure you only have the image subset you created from the image of 27th July 2011 
open (called e.g. 
MER_FRS_1PPBCM20110727_090357_000001013105_00036_49188_0274.dim).  

As mentioned before, the image you are looking at is L1, data as recorded by the satellite 
(TOA), so without correcting for the atmospheric effects. 

First we will check the in situ (ground truth) reflectance data: 

 Open the file In_situ_reflectance_data.xlsx in a spreadsheet program such as Excel. 
Check the reflectance spectra.  

o What are the units?  
o In what order of magnitude is the maximum light intensity? 
o In which colour is the maximum intensity recorded?  

Now we will compare this with the L1 satellite data: 

 Optical > Spectrum View (icon with a graph) 

 Standard the window is shown as a pop-up. To simplify using it you can select it by 
click-hold the left top “spectrum view” tab and drag it to the place where also the 
Colour Manipulator is. 

 
 

 Now navigate over the image, reading the reflectance spectrum in the Spectrum View 
window.  

 Check out the differences over clouds, land, water and the different parts of Lake 
Peipsi: 

o What are the units? 
o In what order of magnitude is the maximum light intensity over the water 

surface? 
o In which colour is the maximum intensity recorded over the water surface?  
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o Why is this colour different than that recorded in the in situ data? 

 
After correction for the atmospheric effects, the reflectances derived from the satellite should 
be similar as the in situ data.  

We will now apply the CoastColour atmospheric correction schema to retrieve L2 
(atmospherically corrected) data: 

 Optical > Thematic Water Processing > MERIS CoastColour Processors > 
CoastColour Atmospheric Correction 

 
(BEAM screenshot) 
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 Keep all parameters according to their standard settings, just check on the tab 
“processing parameters” what is set for “Write all reflectance as” (this should be 
RADIANCE_REFLECTANCES) 

 Make sure you select the correct folder to store the image >> Run 

 
(BEAM screenshot) 

 After the CoastColour atmospheric correction, click OK and Close  

 Scroll down in your “Products Explorer” window, select the new image by clicking it 

 Open again a RGB image view (Window > Open RGB image view > MERIS L2 
Tristimulus) 

o What happened with the land? And the clouds? 
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Now we will compare the L2 satellite reflectance with the in situ reflectance data: 

 Open the Spectrum View window (icon with a graph) 

 Right-click the Spectrum View window > Auto Range  > Range axis 

 Now navigate over the image, reading the reflectance spectrum in the Spectrum View 
window.  

 Check out the differences over different parts of Lake Peipsi. 

 Compare the “reflec” values with the reflectances of the in situ data: 

o In what order of magnitude is the maximum light intensity over the water 
surface? 

o In which colour is the maximum intensity recorded over the water surface?  

o Is there still a difference between the satellite data and the in situ data? 

If you are done you can close the Spectral View window. Keep the L2 image open. 

 

Part 2 Extra analysis 
We can also validate the atmospheric correction results by extracting the reflectance data for 
the pixels at the in situ stations and comparing the reflectance spectra per station in the 
spread sheet. 

 Open the Pin Manager ( ) and click-hold-drag the window to a convenient 
location. If the Pin Manager icon is not in your standard view, you can find it via View 
> Tool Windows > Pin Manager 

 Import ( ) the in situ station locations (File: In_situ_locations.placemark (in the 
folder Additional data)) > open 

 Select the funnel icon ( )  >> select all “reflec” bands (scroll down) > OK 

 Export the data ( ) to a text file and call it Exported_reflectance_data.txt) 

 Open the Exported_reflectance_data.txt in your spreadsheet program, which will lead 
you trough an import function. >> select “separated by tab”. 

 Now plot the L2 MERIS reflectance spectra into the plots that came with the in situ 
data spreadsheet. 

o How did the atmospheric correction perform? It is important to check the intensity, but 
also the spectral shape (which is key to retrieving concentrations) 

 

Part 3 In water component retrieval 
Chlorophyll-a is the main pigment of algae, and therefore a good proxy for the algal biomass. 
Chlorophyll strongly absorbs around 672 nm, which means that less light is reflected in these 
wavelengths. If you check out the in situ reflectance measurements 
(In_situ_reflectance_data.xls) you will notice a strong dip in the intensity at this wavelength, 
which is caused by chlorophyll-a absorption.  
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We will now apply an algorithm to retrieve the chlorophyll concentration. The algorithm is 
developed by Gons (2005), with a small adjustment to accommodate radiance reflectance 
instead of irradiance reflectance as input (to do this, we multiply by π). 

The equations based on Gons (2005) can be entered in: 

 Raster > Band maths (or, if you use BEAM: Utilities > Create Band from Math 
Expression) 

First create a band for the backscattering ratio: 

 Name: Bb 

 Band math expression: 1.61 * (reflec_12 *PI ) /(0.082 - 0.06 * reflec_12 * PI) 

 You can also use the Edit Expression button 

 

 
Next, create also a band for chlorophyll: 

 Name: Chl 

 Band math expression:  
((reflec_9 / reflec_7) * ( 0.70 + Bb)  - 0.40 - pow(Bb, 1.06))/0.014 



Global Lakes Sentinel Services (313256) 

 

 

21 of 30 

 
Now use a nicer colour scale:  
 
 Colour Manipulator >  Import colour palette from file (the icon with the printer) >> 

navigate the the additional data folder > Chlorophyll_colour_scale > automatically 
distribute points: no 

 
Check out the concentrations: 

 Pixel info (that is the tab next to Product Explorer) 

 Move around over the image to read the concentrations: 

o Can you still see the spatial patterns that were visible in the L1 RGB view? 
o What is the general difference between the northern part of the lake (Peipsi 

s.s.) and the southern part (Pihkva)? 
o Are the concentrations at the north-western coastal area of the northern part 

of the lake (Peipsi s.s.) higher or lower than in other parts of the lake? Does 
this make sense? 
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We can also validate the retrieved Chlorophyll-a concentrations by extracting the 
concentration data for the pixels at the in situ stations and comparing them with the 
Chlorophyll concentrations that were measured in situ (sampling+laboratory). 

 Open the Pin Manager ( ) and click-hold-drag the window to a convenient location 

 Import ( ) the in situ station locations (File: In_situ_locations.placemark) > open 

 Select the funnel icon ( )  >> select the Chl band (scroll down) > OK 

 Export the data ( ) to a text file and call it Exported_concentration_data.txt) 

 Open the file In_situ_concentration_data.xls in year spreadsheet program. 

 Open the Exported_reflectance_data.txt in your spreadsheet program, which will lead 
you trough an import function. >> select “separated by tab” . 

 Now create a scatterplot with the L2 MERIS Chl data versus the in situ chlorophyll 
data. 

o How did the concentration retrieval perform?  

o If you zoom in on the calculated chlorophyll band and check the ‘Pixel info’ tab, can 
you explain the results? 

 
 Close all products you have open before continuing with the extra analysis (File > 

Close All Products) 
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Part 3 Extra analysis 
Another method to information on phytoplankton blooms and check for the presence of 
cyanobacteria is the Fluoresence Line Height (FLH) method. This algorithm can be used on 
TOA reflectance data, so there is no need for a functional atmospheric correction. It does not 
deliver concentrations, but an ‘index’ value. 

FLH = L681-1.005*[L665 + (L709-L665)*((681-665) / (709-665))] 

where L indicates radiance in specific MERIS bands.  

Note that the fluorescence only gives a relatively weak signal in a region of the spectrum 
where water absorption and TSM scattering can be substantial. Therefore, the Chl-a signal 
must be strong enough. According to Palmer et al. (2015), it is especially suitable to those 
lakes where Chl-a concentration is >10 mg/m3. Negative FLH values indicate the presence of 
CY bloom and correlate with bloom magnitude, since CY do not produce Chl-a fluorescence 
signal near 685 nm, but they produce a signal near 665 nm. Positive values indicate lack of 
CY (Palmer et al. 2015). 

 
Calculation of FLH 

 Because this algorithm uses TOA data, first to open a L1 image of 27 July 2011. This 
can either be the original .N1 image or the subset you created in the first steps of the 
exercise. 

Next, process an image with FLH and analyse the results:  

 Raster > Band maths (or, if you use BEAM: Utilities > Create Band from Math 
Expression) 

  Name: FLH 

 Band math expression: radiance_8-1.005*(radiance_7 + (radiance_9 - 
radiance_7)*((681-665) / (709-665))) and click OK to calculate 

 If it does not open automatically, open de FLHG band by double clicking it in the 
‘Product Manager’. 
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 Apply the FLH colour scale (Colour Manipulator > 'file' symbol to import colour scale 
from file, select the FLH scale from the folder 'additional data') 

You will see that also for the land FLH values are calculated. To remove the land: 

 Right-click the FLH band in the ‘Product Manager’ > Properties > fill out the valid pixel 
expression by clicking on the button with three dots (see image below):  not 
l1_flags.LAND_OCEAN 

 
o Compare the patterns in the FLH band you just calculated with the Chl band 

calculated via the Gons method 

You can also extract the FLH values with the Chl in situ data (using the Pin Manager, 
methods see earlier in this exercise).  
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4 More information and further reading 
This lesson is based on the following report:  

• GLaSS Deliverable 5.2, 2015. Global Lakes Sentinel Services, D5.2: Shallow lakes 
with high eutrophication and potentially toxic algae. TO, SYKE, WI, CNR, BC, 
VU/VUmc. Available via: www.glass-project.eu/downloads 

 

The report is suggested for further reading. It contains processed data for several years for 
Lake Peipsi (time series), but also for these shallow eutrophic lakes: 

• Tuusulanjärvi (Finland) 

• Ülemiste (Estonia) 

• IJsselmeer, Paterswoldsemeer and Westeinderplassen (Netherlands) 

• Müggelsee (Germany) 

• Trasimeno (Italy) 

 

For more information on GlaSS, and to download all public reports: www.glass-project.eu.  

 

http://www.glass-project.eu/downloads
http://www.glass-project.eu/
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